Cannot enter to End of TIme location after completing Save Refuge quest as well as enter to any other location

Cannot enter to End of TIme location after completing Save Refuge quest
It shows connecting for a short time and does nothing. Waipoint in End of time is locked
Uploaded video to Youtube
Player.log (262.9 KB)

Update. It seems I unable to move to any locations from The lower district neither using map nor using Town portal

I have the exact same problem. Hopefully it’ll get fixed soon.

1 Like

Update. I created a new character it was able to reach the End of Time. But sympthoms were close to the last one. When click on time rift it show connecting for the short time and nothing I waited for some time it put me to the End of time location then

Same Problem here, Also cannot travel to an other location. Neither per Waypoint, nor per portal.

Exact same problem.

I’m also blocked like that for whole day

also cannot progress here

Same problem here

same problem here - any response from the devs?

Have the same problem for the last 6 hours… dont want to make a new character :smiling_face_with_tear: Hope they can fix this.

Hold mouse1 (left bottom) and wait, it worked to me =)


Just passed this. did exit game, entered and fought boss again 4 times, and finally i’am an the end of time.

I just changed my region from East to Central and was able to get into End of Time, after failing to get there three time previously.

1 Like

After 3h it worked. Killed no idea how many times this boss. And clicked no idea how many times in the portal. Fingers crossed for all of you!

1 Like

Same here stuck now after all of you have reported this issue…

Its just slow I entered after a couple of minutes

1 Like

Same problem here. Been 10 minutes and it won’t take the portal

Same here - I knew I shouln’t have bothered trying online play.

It is not stuck, but you must turn around from armory npc, it is located at the top.

see my post at the top