Cannot enter game with Cycle characters

Whenever I click “Enter Game” with any created Cycle character, nothing happens.

I can play with my legacy characters and have no issue when I create a new Cycle character, but the ones I have played before are unplayable. I can click the button but after 0.5s I click it again but can’t enter the game.

On the top right corner it shows up the Minimap UI, with current time and the character location is “Character Selection”.

It started after patch.

OMG, I thought I was the only one. I can’t enter the game with my offline characters after the recent patch. Somehow, my one online Acolyte is also bugged. I can enter the game with that one but I am stuck in place and it has my offline marksman skill tree. I tried a few things and it looks like I can make a new online character and play it. However, making another offline character just gets me stuck in the first loading screen after the cutscene indefinitely.

EDIT: I found a solution! It’s on their discord. It looks like we have an offline corrupted file. In my case, it was the STASH_CYCLE_2_0 file. I followed the steps to fix it. It’s pretty straightforward. Go to: Discord

1 Like

Well it might seems that I’m a selfish bastard, but Im glad that Im not the only one with this problem. Encounter this problem 4 days ago.

It worked! Same file for me. I couldn’t believe my eyes when the loading screen shower up.

Thank you very much.

Have the same problem, but with legacy character. I can create the new one in Cycle and it works fine, but legacy character didnt work or even Enter the world

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.