Black screen/no video during Echo Play after last update

When I am in the Monolith of Fate during transitions from either the Monolith or to the Echo the screen will go completely black. I can not see anything. I can still move and click on things. I can pick up items or activate the chest or portals. It happens sometimes as little as one echo or I can get a few done before it happens. it has happened everytime I have played the game. I have changed the graphical settings to see if it would fix it. I have even tried switching characters but the black screen persists to the main screen. I can see the menu when I hit escape. The only way i can correct it is to completely exit the game. I have included the last two log files and the screen shot of what it looks like when the screen goes black
Player-prev.log (774.7 KB)
Player.log (844.0 KB) (351.0 KB)

Any help would be appreciated.


Have you tried to reverify the files in steam?

No I have not. Doing that now. Will give update on status soon.

Yes I verified the files. And it still went to the black screen after two echos were completed when I left the echo. I have attached the log from the run i just did.
Player.log (1.1 MB)

I have same problem after last patch.

Yeah it frustrating because I really want to play

Hey there… There is a literal crap ton of Canvas, Text, Rendering & Texture errors in your player.log - hopefully the devs can figure out what is going on from this.

As some of them are Direct3D (part of DirectX) - can you double check your GPU driver version and update it with a clean install if its older than a few months… and make sure its running on default settings only and not some silly Geforce Experience recommendation.

Hey there… welcome to the forum…

Please can you post your player.log so that the devs have another debug log to reference/compare with others having the same problem - i.e. if you have the same error messages then it could possibly confirm where the devs could start looking for the bug…

If it happens again please post your player.log here as well.

After updating the graphics driver, everything goes properly again.

1 Like

I will be checking that soon. I have not had time yet

@KissingAiur @vapourfire Updating the graphics driver looks like it fixed the issue. i ran about 5 or 6 with no issue when i was having the issue within 1 or 2.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.