My Account
× My Account Forum Buy Now

Last Epoch Forums

Beta Download takes forever on AlphaLauncher

i started the Alpha Launcher to play the beta, which I thought would work based on Forum research. Now the Download really takes forever… It switches from 100KB/sec to 0 like every 20 seconds. In 40 Minutes I managed to get 76MB (3.2%)… Any solutions?

I have the same problem, right now im at 202KB/sec :slight_smile:

Same for me 204.kb/sec…

One hour later :confused:

If Download slow close and reopen the launcher that fixed it for me.

Another 6 hours later… :frowning:

77% for me after 10 hours dl =(
( i can dl at 60 mo/secondes with my connection… )

same for me. I closed it and found the Beta launcher download and tried that and got really slow download. Then tried closing and relaunching and that helped

Sorry about this guys! Our service provider is working on the problem. The information we’ve gotten from them is that some of their servers have been reaching capacity, causing subsequent connections to be redirected to servers which are further away.

One workaround would be to link your accounts if you also have a Steam account, as this will allow you to download and install the game through Steam as well / instead.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.