Beta 0.9l Patch Notes


  • Likely fixed a bug that caused players to be unable to enter the Boss Room of Dungeons.
    • We have spent many hours confirming this fix so we’re pretty confident it’s resolved but aren’t totally certain since the bug didn’t happen 100% of the time. Please let us know if this bug still happens for you after updating.
  • Fixed a bug where you could enter a Dungeon without consuming a key in some situations.

Monolith of Fate

  • Fixed a bug where echoes could fail to spawn enemies, including bosses or quest objectives, if Ring of Shields was active while loading the echo.
  • Emperor of Corpses’ Soul Bomb now deals less damage the further you are from the center of the ability.
  • Fixed a bug where monolith modifiers could be duplicated. If a timeline had an impossibly high number of mods, those duplicated mods will be removed the next time you enter an echo in that timeline.


  • Fixed a bug where using traversal skills while you had certain other skills on your bar (including Summon Skeletal Mage) caused a stutter to build up with each use, resulting in a game freeze after enough uses.


Thank you all for continuing to report bugs and engage in the community. As you’ve probably heard, we’re gearing up for our next content release on May 25th, so we’re shifting focus towards finishing that update.

We are still working on bug fixes in the background as well, but they’re likely to be included in the 0.9.1 content update rather than a hotfix to 0.9. But, we can still make hotfixes if necessary.

One bug we’ve recently become aware of is if you delete an Offline Character Found character and then load or make another character, progress will not be saved. If you restart the game after deleting the Offline Character Found character saving will work properly. We’re working on a solution for this.


Thank you most kindly. I can finally continue my FG grinding without “Oh crap, forgot to wait for RoS to end again”. :stuck_out_tongue_winking_eye:

Ooooooooo, that’s interesting. Is this for normal and empowered? And how much if a % does it drop to at the edge.

there’s huge frame drops on the arena monoliths, ping fine, normal monoliths are fine. just the arena ones…

waiting for a fix to “A” key, when you command minions, thorn totems and storm totems stop to attack, thanks in advance ; )

1 Like

Yeah…no…dungeons still bugged for me…

and same for Soulfire…cmon guys…pleeease i wanna play the game :smiley:

By all accounts you could previously unbreak your no-doors-allowed-account by grouping with someone and going to door. Might be worth a shot.

Likely fixed a bug that caused players to be unable to enter the Boss Room of Dungeons

Nope, not for me, I haven’t tried all the dungeons but still can’t do Soulfire :sob:

Since I started playing, I have never seen the end of a dungeon… I never manage to open the boss room. I’m cursed :scream:

Hello, the dungeon door opening at the end of dungeons is still occurring. Tried the light Lightless Arbor and Soulfire - could not open either door. Keep me posted thanks

1 Like

Tried arena, soulfire and lightless arbor last night with my new druid (online). 2nd door on lightless I just got an instant “respawn” message. Never saw what happened, but I doubt anything could have killed me that fast? So I guess I got through the door, but got punished :stuck_out_tongue: Arena and soulfire worked this time around.

Just tried Lightless Arbor last night, no dice gut stuck at the last door before the boss fight. Door is highlighted but clicking on it does nothing.

Good luck on the bug fix! I don’t envy hunting this one down. Happy to provide whatever info might be helpful to recreate it.

How long did you wait? I ask because I’ve done the Temporal Sanctum twice now and both times the last door before the boss fight seemed to hang but after waiting for what seemed like an eternity it finally loaded for me.

I don’t know why it took so long when nothing else does but it did.

Huh, I waited probably like 5 minutes. I’ll give this a try next time!