Beta 0.8.2g Patch Notes

Nice touch right here. Thank you!


1 Like

Thank you so much for this! It fixed the issue I was having activating Empowered Monoliths.

Thanks so much for these changes! Really reduces the grind.

Welp, guess my character is stuck for another week then :frowning:

Empowered Timelines still not working for me…
Blue box was clickable again but nothing happened/changed after the cut scene. Didn’t log out or go to a different zone after clicking it.

EDit: For some reason I could click it again and did so, now it works, yay!

Ty! :slight_smile:

Game keeps crashing on startup screen.

Every time I press the START button to start a monolith the game crashes. Music keeps playing but nothing happen. I can’t play the endgame anymore.

Have you tried verifying the game files first? To do so:

Close the game (if not already) → right-click Last Epoch in your Steam library → Properties → Local Files → Verify Integrity of Local Files

It may or may not resolve your issue, but hopefully it does.

Yeh, Same. And Ctrl don’t work. And make the assignment of the buttons on the mouse, pls.

Fantastic, that worked. Thanks!

1 Like

Wait a sec, Yogi just got a buff. Charge on, you picnic loving earthquake fluffy bastard!

Stability changes are so nice. Not as grindy to get a blessing now. Spires aren’t as rippy now. Two major complaints on the LE reddit now crossed off. Thank you EHG you guys are rockin it.

This is appreciated. It was a bit nerve wracking to level up in the middle of an arena and be suddenly vulnerable :smiley:

Overall good changes not a fan of the stability changes myself its going to lower my time spent playing endgame in total. but happy with all the other changes. keep up great work <3

Didnt see the patch notes prior to work this morning

I have multiple characters to see if Empowered monoliths work on them

Crashing every 10 minutes spamming Devouring Orb as of last night still, its fine if you have 1-2. start spamming and client hangs/freezes

Verifying solves the problem. Just leaving a comment to let others with the same problem know that they are not alone :slight_smile:

1 Like

Have you posted that as a bug (with the usual bug & crash reports) 'cause I’m not getting any crashes while spamming my 1.2s cooldown DO?

The moment I saw the final quest echo cut to 750 my first thought was,“ooh! They are nearly ready with another endgame system!”

Maybe I’m just Mr Sunny Optimism :slight_smile:

1 Like