Any workaround when stuck on echo quest?

Hello,

Is there any workaround for my problem?

Doing Fall of the Outcasts Timeline (first playthrough) and I want to do the 1st Echo Quest (The Ransacked Camp). When I try to open this quest, I get an endless loading screen.

I saw in the bug report forum that this is a known bug.

But, that makes it impossible for me to complete this timeline and just can’t progress anymore with my character…

Is there any known workaround?

I understand that empowered timelines let you only do the 3rd echo quest (boss). But, normal timelines, you have to complete all 3 of them.

thanks,

Hey there and welcome to the LE forums.

Couple of things I would try (in case you haven’t).

  1. Verify game files
  2. Delete or backup le_graphicsmanager.ini (resets graphic settings)
  3. Reinstall LE entirely

Not sure if there are other possible solutions.

Thanks for the quick reply.
I tried all 3.

  1. Game files are OK according to Steam.
  2. Tried, didn’t solve the problem.
  3. Just did, didn’t solve the problem.

I guess… next step is waiting for the 0.9.2 patch next week and hope for the best…

Also tried to re-install driver.

BTW, I can actually play. I hear my skills, menus opening/closing, etc. But, the loading screen stays there…

Hey there… Something you may also want to try.

I have experienced odd issues with Timeline quests occasionally not loading and I would immediately run a normal echo or two in the same timeline and then try the echo quest again. Sometimes this has worked.

Also, if you have any skills on autocast or minions etc that resummon when you try and load the quest - temporarily disable that autocast and see if that can help.

Also, there were some problems with Sentinel builds that couldnt load specific timeline quests but that was fixed a while back in one of the 0.9 bug patches. Its entirely possible that you may have a specific setup that is causing an issue and it may need to be reported in the Bug section of the forum for the devs to check. This is obviously easy to test if you have multiple chars - see if you have the problem with the same quest echo on different chars or if its a specific quest echo that is causing the problem on all your chars.

And yeah, 0.9.2 may inadvertently solve the issue too - but it sounds like its gonna be a big update so who knows what it fixes (or breaks).

Yeah, thanks for the idea.
It is my only character and I intend it to be my only character before 1.0 due to the time I have to invest in games.
I will wait for 0.9.2 and see…

If it doesn’t work, I guess I will format my computer. It is due for a good clean-up and fresh start anyway. I will see if this solves the problem.

What sucks is this bug is currently blocking me to progress in the game, I am in a dead end right now haha!

While I always advise good computer housekeeping and maintenance, I wouldnt place much hope that this process will resolve an in-game bug. At most it may help with any old driver issues and general performance etc, but in this instance it may not be a silver bullet - assuming that your system isnt REALLY suffering generally.

With beta games its always hard to figure out exactly what is happening or the primary root cause of something.