Acolyte - Skeletal Mage - Cryomancer and Death Knight not properly spawning

Hello,

I ran into 2 bugs with the Acolyte Skeletal Mage skill.

  1. Picked the Cryomancers Node.
  • The very first time using the skill I got 2 cryomancers and 1 skeletal mage. When the cryomancers died and I cast the skill again, I was only receiving skeletal mages.
  • Once i have 3 skeletal mages, casting the skill multiple times (up to 10 I tried) only gives me skeletal mages and I never see a cryomancer.
  • I removed the skill from the action bar to despawn the skeletal mages. Then put it back on and cast it, and again I never see a cryomancer.
  1. I picked the Death Knights node. I now have both Cryomancer and Death Knights activated.
  • Same situation as above, except I never see a Death Knight.
  • Is it supposed to remove even my cryomancer selection from the summon pool?

Thanks!

1 Like

I specialized in summon skeletal mage on my acolyte and skilled into Pyromancers and was able to summon normal mage together with pyromancers.
When I also skilled into cryomancers, I was only able to summon normal skeleton mages. No more pyromancers were summoned and also no cryomancers.

update:
-I skilled out of cryomancers and was able to summon nnormal mages + pyromancers again (good)
-then I put a point on the passive tree (necromancer tree) into +1 maximum skeleton mage and I was not able to summon pyromancers. only normal mages were summoned (bad)
-then I skilled another point into the summon skeleton tree (argonautic speed, gives attack and cast speed) and I was not able to summon pyromancers anymore…

This happened a few more times and it looks like to me that whenever I put a point into my summon skeleton mage tree it switches from being able to summon both pyromancers and normal mages to only mages (and then to being able to summon both again on the next skillpoint)

update 2:
changing zones removes my ability to summon more than one type of skeleton mage (mostly I am only able to summon only the normal mage, but sometimes I am only able to summon pyromancers)

I have also had this issue, temporary fix is to exit to main menu then log back in, very annoying but I just get to next waypoint so it sort of works.

Also had this bug, was ending either with 3/3 normal mages or 3/3 cryomancers. Can’t put my finger at the exact moment when it goes wrong, i have Grave Passage with Death’s Cavalry, and maybe it has something to do with Assemble Abomination?

I use many different type of invocations because I like variety. Though, in the middle of the fight agains Yulia and the two other bosses in front of the Immortal Emperor, I suddenly stopped being able to summon Pyromancers and standard Skeleton Mages, and only Cryomancers are spawning. All the others invocations works fine for me.

Edit : It happened again against the Wendari Patriarch and Matriarch, it seems that when I connect to the game I can invoke just fine, but when my Mages are killed I can only reinvok Cryomancers for some reason.

I can confirm this bug, just happened to me as well.

I’m not sure what caused it, might have been a map change or the skill point I invested in “Argonautic Speed” in the Summon Skeletal Mage skill tree.

EDIT: I just got a skill point for the Mage Skeleton tree. When I used that skill point it worked again for some time until it was broken again.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.