0.9.1c Patch Notes

Bug Fixes

  • Fixed Item Linking not working. Press ctrl + right click to link up to 3 items in a chat message. Open the chat window and hover over a linked item to view it.
  • Fixed a bug where Weaver’s Will items upgrading caused a performance stutter.
  • Fixed a bug where parties would sometimes incorrectly use US East for their server region rather than the desired region.
  • Fixed a bug where the Burning Daggers created by Cinder Strike’s Firebreathing were not affected by the Pillager’s Gold unique.
  • Fixed a bug where the Increased Chance to Find Potions affix had no effect. This stat only worked when provided by the unique affixes of The Scavenger and Melvern’s Writ or by passive tree nodes. This bug also impacted the Pillager’s Gold unique.
  • Fixed a bug where Spirit Plague’s Rotten to the Core node could not be allocated.
  • Fixed a bug where Cinder Strike’s area of effect was not increased by its Blast Wave node.
  • Fixed a bug where Volatile Zombie’s Necromantic Fervor also gained the benefit of the Vital Ward node without allocating it, and Vital Ward still gave the health gain from Necromantic Fervor when allocated.
  • Fixed ground visuals projecting on top of Storm Crows.
  • Fixed a bug where The Shrouded Plateau was missing terrain in some areas.
  • Fixed the prices for Epoch Points in the store always displaying in $USD, rather than your local currency in Steam.
  • Fixed the polearm visual variant of Multistrike and Vengeance being rotated incorrectly.
  • Fixed a visual issue with Voidtouched Archivist’s Ice Mortar and Voidfused Armor’s sword attack.
  • Fixed Wraith and Volatile Zombie minions from party members having minimap icons.


  • Improved AFK detection: interacting with the UI, pressing buttons, etc. will prevent you being flagged as AFK. The time before being kicked has also been increased to 20 minutes.
  • Because the Increase Chance to Find Potions affix was having no effect before, we’re being cautious with the total amount that it can give. The maximum value at T5 has been reduced to 60% (from 70%) and the maximum amount at T7 has been reduced to 120% (from 140%). Additionally it can no longer roll on rings and any existing potion drop rate affixes on rings have been changed to armour affixes (the armour affix can still not roll on rings naturally).
  • Reduced Bolroth Stomp hitbox size especially at the sides of the Bolroth.
  • Bolroths now stop turning (finalize target) 0.35 seconds into their Stomp attack. Previously they could turn right until the end.
  • Regular enemies in Monolith Ambushes gain 15% more health (from 10% more damage and 5% less health).
  • Bosses in Monolith Ambushes gain 5% more damage and 5% less health (from 10% more damage and 5% less health)
  • Minibosses in Monolith Ambushes gain 20% more damage and 150% more health (from 40% more damage and 150% more health)
  • The Osprix Monolith Ambush contains 1 fewer lightmage.
  • Added final 2d art for Pillager’s Gold, Ambitions of an Erased Acolyte, and Gambit of an Erased Rogue.
  • Improved the quality of the preview images for the Soul Eater cosmetic armor set.
  • Updated the tooltip for Corruption to mention the Sanctuary of Eterra.
  • Baby Scorpions no longer have minimap icons.


Thank you for continuing to report bugs; we keep an eye on everything that comes through the Forums. Here’s much of what we’re currently working on fixing or improving:

  • Chat sometimes re-enables itself - we’ve found that this is caused by joining or leaving a party or town server (because this joins/leaves a chat channel).
  • Rarely, a failed attempt to transition to another zone can become completed after loading a different character.
  • Further Ambush encounter scaling changes.
  • Adjusting new Chapter 1 enemies that are problematic when scaled to Endgame.
  • The window for reducing corruption in the Sanctuary of Eterra does not disappear after being used.
  • Maul with the Skull Crusher node is not affected by some “when landing” effects in Fury Leap.
  • Shield Bash fails to cast sometimes when you have increased attack speed.
  • Summoned Spriggans don’t gain the Cold Minion tag when cold converted.
  • There isn’t a quest marker prompting you to walk to Balthas after defeating Orian and Emberwing in the Summit in Chapter 1.
  • Cosmetics and armor visuals are sometimes invisible (usually fixed by re-equipping or going to the next zone).
  • Echo Completed portals don’t use equipped Portal cosmetics.

There was a big lag bug happening yesterday with my Lich. Whenever I used transplant, I would then be shooting my souls from where I teleported from, then after a few seconds I get teleported back to where I teleported from. Is that part of the fixes too or are you working on that next?

OMG why u remove the find potion affix on rings … there is no reason to try burning daggers with this change bec. it will be trash there is only 1 More dmg note in the cinder strike tree and now ur missing 2 affix for the flat dmg … idk why u put items in the game for some mechanics and nerf it sooo much that the item will be just trash and not worth picking up…


Yay, item is usable! My t6 potion chance scavenger is no longer bugged!

And there goes any reason to actually chase alternative gearing options! if im correct this means the only slot it appears on is belt and amulet, meaning you just lost half your potion find scaling options.

We didnt even get to try the item with it working before it was nerfed :confused:


Any chance of this tracking change being put on ruby captain arjani as well? His tracking is nuts.

What about updating the unique / legendary item pages with the introduction of weavers will items?

1 Like

You didn’t lose anything. You gained. Reading comprehension people. The stat didn’t work at all from affixes previously. It will be better than it was.


Thank you for fixing AFK timer, this makes a lot more sense now!

1 Like

I can play offline but can not get into the game online or when I create a new character

I have been playing the game offline with several characters for over 336 hours and have had no issues. Once the 0.9.1b came out I installed it and created a character so that I could play online and play the new Rising Flames. Every time I select the server and select online, I get the character screen and I select my level 1 Rogue character and select enter game.
I get the dialogue window that says connecting and then 20 to 30 seconds later I get a dialogue window that says Lost connection, you have lost connection with the game server.

When I create a new level one character and try to enter the game that way after creating a new character it appears that the game tries to load because the first area screen shows,
with the name in the lower left corner I think its called “the something road” and then it does the same thing with a dialogue message saying lost connection You have lost connection to the game server.

I have tried the following things;
Uninstall and reinstalled the game
Verified all 994 files are validated through Steam
Turned off the firewall and got the same lost connection message
Tried a different network
Tried a different computer.
Logged onto my router and went through the settings

I have a Acer Predator Helios 300 I7 11th generation processor with 16 GB RAM, NVIDIA RTX GEFORCE 3060 and 500 GB SSD with a 1 TB HD

Like I said I can run the game all day long and play offline but when I select offline and select my characters to play this seems to be on the previous version of the game prior to Rising Flames 0.9.1b. I have no MTX / shop or any of the new things that are in the latest version Rising Flames 0.9.1b.

In the upper left hand corner it shows Beta 0.9.1b

Any help would be appreciated.

nah its dumb i worked on a Burning dagger BD with Cinderstrike u only have 1 more dmg Note in the cinderstrike tree i just try 5 min ago the burning dagger again with the new relic and its useless af i have a t7 belt and t7 amulet with find potion and pretty good gear in the rest of the slots and its not worth doing (4k crit on a dummy xD) i mean heay we have a new unique in the game that has a useless mechanic on it again noice

1 Like

So, to clarify, armor affixes can’t roll on rings. But any potion drop have been changed to armor affix? Is that going to be confusing down the road when someone forgets this patch and complains about never finding a good upgrade for their ring?

Or am I totally misreading/misunderstanding this?


Nice update! Especially the timer. I’m sure everyone else will appreciate it.

By the way, QoL low priority but any chance we’re ever going to get the clock back in the upper right?


Great update! Thank you!

Any word on updating chat so that when it’s disabled it doesn’t show the conversations? Disabling chat isn’t about preventing me from posting but me not wanting to see chat at all.

nice patch. thx for the 10 minutes loading time between areas

1 Like

“Chat sometimes re-enables itself”:
Chat always enable itself in offline mode when logging on, even if it says its disabled. Floating HP bar also disable itself when logging on


Getting stuck in loading screens since this patch…although some are saying loading times are 10 minutes. Letting you know right now I won’t wait that long. Game’s good, but not that good.

After patch 0.9.1c, loading into the game seems slower than normal. Also, when I get to the character screen and select my character and press enter game, it kicks me after about 2 minutes and says “disconnected from server.” It did this with each of my 3 characters, as well as a new one I tried to start.

While typing this, the character screen disappeared and now reappeared, but only 1 of my characters of the 3 are showing up. I was able to load in with that character. Upon leaving the game to go back to the character screen, it doesn’t show my characters and I have to exit the game.

Now…I relaunched the game and it shows all my characters, but is stuck at “connecting,” and it appears that it is loading correctly. However, everything seems to load slow, Monos, ladder, etc.

Hopefully, this is getting better for everyone!

Are performance issues being looked into? Noticing since 0.9.1 that loading times are 2-3x longer than they were before, also getting lots of lag/stutters even though latency sits at around 20. Packs of mobs just freeze for a second then everything rushes in.

Glad to see the AFK fixes, was really annoying getting kicked while changing passives around or crafting.

Also, it seems strange to nerf the potion find % when it wasn’t working, how can you tell it needs a nerf if no one could use it before?


I agree with you. I also just tested and the relic that gives burning damage per potion chance, still doesn’t work properly and even if it works the nerf makes it not very useful.

1 Like

Can’t get into Monolith of Fate area at all now no matter how long I let it sit there. Eventually it tells me I lost connection. I can get everywhere else I tried though… scratch that - after some more testing getting anywhere seems hosed. Guess I’ll wait until tomorrow when all the fixes get fixed.

can’t even load into game to see the fixes… guess i’ll wait for 9.1d