Lvl 70-Monolith Blood, Frost......etc Quest progress stuck!

Character Creation was fresh new with the new 8.2 patch
As obove said im stuck at infinity boss defeating without getting quest complete and i cant chose rerolling blessing in this area.
Hard stuckt at this monolith>.<
Alrdy tryed:
Die till stability get loss, than get again anough stability to get acces to the boss, no change in rusult.

After you kill Formosus are you able to talk to the NPC?

Yes after speaking to him no result. It seems like the game have no quest for me that i can compelte somehow

Anything weird happen entering the boss room (sounds not triggering, animations off etc)? The first time defeating the boss were you also dead? What happened when you spoke with the NPC? Did you hear a quest sound effect trigger? Was it correct dialog? Did he successfully get out of his cage? Anything weird happened before you entered the monolith that you can remember that could have caused the quest to break?

As much information here you can give me would be great.

After speaking to him change nothing as the game dont give the quest, no special sounds nothing. And i dont get green portal as u see, as its appear always if u successfully done it.

Is there anything you could remember happening before this that could have resulted in the quest being broken?

Also have you tried to relog and see if that works?

Before that i alrdy done this one time and than done it twice again to reroll blessings cuz i want that staff drop blessing…
Third Run:
I had finished the first two quests and had ~320 or something stability than ive done the boss wich resets the web and it gaved me 82 stability for it, so i done him, after that i had anough stability to contest the last questen and the boss and than it appears.

The first time you completed defeated the boss did you happen to port out before talking to the NPC?

Yes i did! cuz he had only shit options and i dont wanna mess my drop rate up with things i dont need, so the first time i just closed the game cuz u guys not implimented option to take nothing of them…!!!

Alright, I have made a note of this.

I would advise you not to exploit bosses in this matter because it seems it can now break your quest state. Hopefully, we can resolve the issue soon in a future hotfix.

Thank you for your report.

1 Like

“I would advise you not to exploit bosses in this matter because it seems it can now break your quest state.”
ahh… u not say
Ofc not if i want any progress …

Similar issue here, but I did not TP out after killing the boss for the first time. Character created in 0.8.1 and monolith progress was also started there.
I just wanted to discover the remaining timeline for the first time and this is what happened:

  • Farmed stability for all 3 quest echoes
  • Successfully completed the first two quest echoes
  • Entered the third quest echo and still had the quest active back then
  • Killed the boss, talked to the Frost Clan Wengari
  • Blessing window was empty and only visible for half a second before closing automatically again
  • Nothing else happened, leaving my stuck with the Frost Clan Wengari to talk to

Couldn’t do anything else so I closed down the game, now if I farm stability again to repeat the Quest echo I get the same issue but I don’t have an active quest anymore inside the region. Zipped screenshots from my last attempt are attached. (1.4 MB)

Y sucks hard but i left it now behind and progressed further to lvl 85 Mono, so i hope i will have no progressproblems in the future of end content.

With me the cage disappears before u talk to the chieftain.
The pop up asks to set him free and when I click on it it just closes.
I still get the uniques drop. But can’t progress. End up going to town and doing it again. Done it like 10 times and same thing everytime.

happens after completed the 1st run

Same problem.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.